FIU: University Technology Services - Information Technology
HomeAboutFaculty & StaffStudentsStudents
   Login Now
   Glossary
   Downloads


PC Requirements

Browser Requirements

The University's browser policy concerning PantherSoft supports the use of two browsers based on industry standards: Internet Explorer (IE) and Safari (for Macintosh computers). Please note that access to University administrative systems are guaranteed effective only when using IE 6.0 and above for Windows-based computers, or IE 5.2 and above or Safari for Macintosh systems. If you are unsure which version of IE your computer has, just click on 'Help' when using the IE browser, and then click on 'About Internet Explorer.'

Note: Some University systems may not be compatible with version 6.0; therefore, you may need to have two different browsers on your PC. If you need to upgrade your browser, you can contact UTS Support Center at 305-348-2284

 

 

   FIU Home FIU Phonebook Division of IT CIARA ITSO PantherSoft CE6/WebCT